E: パッケージ   〜を再インストールする必要がありますが、そのためのアーカイブを見つけることができませんでした。

元々は、A3の用紙を分割して印刷したかったので、
posteRazorというアプリのインストールがしたかったのですが・・
以下のようなエラーが出て出来ませんでした。
  ↓

E: パッケージ  zoomを再インストールする必要がありますが、
そのためのアーカイブを見つけることができませんでした。

  ↓
同じようなことが数回あり、解決しないと何もインストールできないという状態。
  ↓

# apt install zoom
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
E: パッケージ zoom を再インストールする必要がありますが、そのためのアーカイブを見つけることができませんでした。

  ↓
原因究明のために
  ↓
# dpkg -l (インストールの状態がズラーッと出てくる)
  ↓
iHR zoom 3.5.392530.0 amd64 (説明 (description) がありません)
  ↓

要望=(U)不明/(I)インストール/(R)削除/(P)完全削除/(H)保持
| 状態=(N)無/(I)インストール済/(C)設定/(U)展開/(F)設定失敗/(H)半インストール/(W)トリガ待ち/(T)トリガ保留
|/ エラー?=(空欄)無/(R)要再インストール (状態,エラーの大文字=異常)
||/ 名前 バージョン アーキテクチ 説明

  ↓
iHR zoom なので、(I)インストール済/(H)保持(R)要再インストール
  ↓

# dpkg -s package
dpkg-query: パッケージ ‘package’ はまだインストールされておらず情報の利用は不可能です
アーカイブファイルを調べるためには dpkg –info (= dpkg-deb –info) を、
その内容一覧を表示するには dpkg –contents (= dpkg-deb –contents) を使います。

  ↓

# aptitude purge zoom_amd64.deb
名前か説明が “zoom_amd64.deb” にマッチするパッケージは見つかりませんでした
名前か説明が “zoom_amd64.deb” にマッチするパッケージは見つかりませんでした
以下のパッケージは『削除』されます:
libxcb-xtest0{u}
0 個のパッケージを更新、 0 個を新たにインストール、 1 個を削除予定、646 個が更新されていない。
0 バイトのアーカイブを取得する必要があります。 展開後に 32.8 k バイトのディスク領域が解放されます。
先に進みますか? [Y/n/?] y
E: ‘zoom:amd64’ のバージョン ‘3.5.392530.0421’ をダウンロードするソースが見つかりません
E: ‘zoom:amd64’ のバージョン ‘3.5.392530.0421’ をダウンロードするソースが見つかりません
E: 内部エラー: ダウンロードするパッケージの一覧を作成できません

  ↓

強制的に上書き
  ↓

# dpkg -i bad-version zoom_amd64.deb
dpkg: アーカイブ bad-version の処理中にエラーが発生しました (–install):
アーカイブにアクセスできません: そのようなファイルやディレクトリはありません
dpkg: アーカイブ zoom_amd64.deb の処理中にエラーが発生しました (–install):
アーカイブにアクセスできません: そのようなファイルやディレクトリはありません
処理中にエラーが発生しました:
bad-version
zoom_amd64.deb

  ↓
ここで、フォルダの場所がもしかしておかしいのでは?と、

コマンド上ではなく、パソコン上のフォルダをドラッグで
  ↓
ダウンロード/zoom → ダウンロード に移動させてみる
  ↓
上記のエラーの、bad-versionを消してみる
  ↓

# dpkg -i zoom_amd64.deb
(データベースを読み込んでいます … 現在 251979 個のファイルとディレクトリがインストールされています。)
zoom_amd64.deb を展開する準備をしています …
zoom (5.0.418682.0603) で (5.0.418682.0603 に) 上書き展開しています …
run post uninstall script, action is upgrade …
zoom (5.0.418682.0603) を設定しています …
run post install script, action is configure…
gnome-menus (3.13.3-6ubuntu3.1) のトリガを処理しています …
desktop-file-utils (0.22+linuxmint1) のトリガを処理しています …
mime-support (3.59ubuntu1) のトリガを処理しています …
shared-mime-info (1.5-2ubuntu0.1) のトリガを処理しています …
Unknown media type in type ‘all/all’
Unknown media type in type ‘all/allfiles’

  ↓
試しに解凍ソフトをインストール
  ↓

# sudo apt-get install unar
パッケージリストを読み込んでいます… 完了
依存関係ツリーを作成しています
状態情報を読み取っています… 完了
unar はすでに最新バージョン (1.9.1-1) です。
アップグレード: 0 個、新規インストール: 0 個、削除: 0 個、保留: 646 個。

  ↓
エラーは出なくなっています。成功。お疲れ様でした。

ちなみに、最初の目的だった、PosteRazorと言うソフトですが・・、

文字化けして使えそうにありませんでした・・。

ちょっと調べてダメそうだったら、アンインストールします。。

ここまで読んで頂きありがとうございました。

何か少しでも参考になれば幸いです。

良かったら気が向いた時にでもまた覗いてやってくださいませ。

よろしくお願い致します。

参考:

Debian 管理者ハンドブック  5.4. dpkg を用いたパッケージの操作